DDI_MEM_PUT8(9F)DDI_MEM_PUT8(9F)NAME
ddi_mem_put8, ddi_mem_put16, ddi_mem_put32, ddi_mem_put64,
ddi_mem_putb, ddi_mem_putw, ddi_mem_putl, ddi_mem_putll - write data to
mapped device in the memory space or allocated DMA memory
SYNOPSIS
#include <sys/ddi.h>
#include <sys/sunddi.h>
void ddi_mem_put8(ddi_acc_handle_t handle, uint8_t *dev_addr,
uint8_t value);
void ddi_mem_put16(ddi_acc_handle_t handle, uint16_t *dev_addr,
uint16_t value);
void ddi_mem_put32(ddi_acc_handle_t handle, uint32_t *dev_addr,
uint32_t value);
void ddi_mem_put64(ddi_acc_handle_t handle, uint64_t *dev_addr,
uint64_t value);
PARAMETERS
handle
The data access handle returned from setup calls, such as
ddi_regs_map_setup(9F).
dev_addr
Base device address.
value
The data to be written to the device.
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). The ddi_mem_put8(),
ddi_mem_put16(), ddi_mem_put32(), ddi_mem_put64(), ddi_mem_putb(),
ddi_mem_putl(), ddi_mem_putll(), and ddi_mem_putw() functions are obso‐
lete. The ddi_put8(9F) function replaces ddi_mem_put8(). The
ddi_put16(9F) function replaces ddi_mem_put16(). The ddi_put32(9F)
function replaces ddi_mem_put32(). The ddi_put64(9F) function replaces
ddi_mem_put64(). The ddi_put8(9F) function replaces ddi_mem_putb(). The
ddi_put32(9F) function replaces ddi_mem_putl(). The ddi_put64(9F) func‐
tion replaces ddi_mem_putll(). The ddi_put16(9F) function replaces
ddi_mem_putw().
DESCRIPTION
These routines generate a write of various sizes to memory space or
allocated DMA memory. The ddi_mem_put8(), ddi_mem_put16(),
ddi_mem_put32(), and ddi_mem_put64() functions write 8 bits, 16 bits,
32 bits and 64 bits of data, respectively, to the device address,
dev_addr, in memory space.
Each individual datum will automatically be translated to maintain a
consistent view between the host and the device based on the encoded
information in the data access handle. The translation may involve
byte-swapping if the host and the device have incompatible endian char‐
acteristics.
CONTEXT
These functions can be called from user, kernel, or interrupt context.
ATTRIBUTES
See attributes(5) for descriptions of the following attributes:
┌────────────────────┬─────────────────┐
│ ATTRIBUTE TYPE │ ATTRIBUTE VALUE │
├────────────────────┼─────────────────┤
│Interface Stability │ Obsolete │
└────────────────────┴─────────────────┘
SEE ALSOddi_mem_get8(9F), ddi_mem_rep_get8(9F), ddi_put8(9F), ddi_put16(9F),
ddi_put32(9F), ddi_put64(9F), ddi_mem_get8(9F), ddi_regs_map_setup(9F),
ddi_device_acc_attr(9S)
Nov 1, 2005 DDI_MEM_PUT8(9F)