Perform Alternate Disk Migration:
nimadm -l lpp_source -c NIMClient -s SPOT -d TargetDisks [ -a PreMigrationScript ] [ -b installp_bundle] [ -z PostMigrationScript] [ -e exclude_files] [ -i image_data ] [ -j VGname ] [ -m NFSMountOptions ] [ -o bosinst_data] [-P Phase] [ -j VGname ] [-Y ] [ -F ] [ -D ] [ -E ] [ -V ] [ { -B | -r } ]
Cleanup Alternate Disk Migration on client:
nimadm -C -c NIMClient -s SPOT [ -F ] [ -D ] [ -E ]
Wake-up Volume Group:
nimadm -W -c NIMClient -s SPOT -d TargetDisks [-m NFSMountOptions ] [-z PostMigrationScript ] [ -F ] [ -D ] [ -E ]
Put-to-sleep Volume Group:
nimadm -S -c NIMClient -s SPOT [ -F ] [ -D ] [ -E ]
Synchronize Alternate Disk Migration Software:
nimadm -M -s SPOT -l lpp_source [ -d device ] [ -P ] [ -F ]
mksysb to Client Migration:
nimadm -T NIMmksysb -c NIMClient -s SPOT -l lpp_source -d TargetDisks -j VGname -Y [ -a PreMigrationScript ] [ -b installpBundle ] [ -z PostMigrationScript ] [ -i ImageData ] [ -m NFSMountOptions ] [ -o bosinst_data ] [ -P Phase ] [ -F ] [ -D ] [ -E ] [ -V ] [ -B | -r ]
mksysb to mksysb Migration:
nimadm -T NIMmksysb -O mksysbfile -s SPOT -l lpp_source -j VGname -Y [ -N NIMmksysb ] [ -a PreMigrationScript ] [ -b installp_bundle ] [ -z PostMigrationScript ] [ -i image_data ] [ -m NFSMountOptions ] [ -o bosinst_data ] [ -P Phase ] [ -F ] [ -D ] [ -E ] [ -V ]
Client to mksysb Migration:
nimadm -c nim_client -O mksysbfile -s SPOT -l lpp_source -j VGname -Y [ -N NIMmksysb ] [ -a PreMigrationScript ] [ -b installp_bundle ] [ -z PostMigrationScript ] [ -i image_data ] [ -m NFSMountOptions ] [ -o bosinst_data ] [ -P Phase ] [ -e exclude_files] [ -F ] [ -D ] [ -E ] [ -V ]
The nimadm command is a utility that allows the system administrator to create a copy of rootvg to a free disk (or disks) and simultaneously migrate it to a new version or release level of AIX. The nimadm command uses NIM resources to perform this function.
nimadm Local Disk Caching
Local disk caching allows the NIM master to avoid having to NFS write to the client, which can be useful if the nimadm operation is not performing optimally due to an NFS write bottle neck. If this function is invoked with the -j VGname flag, the nimadm command creates file systems on the specified volume group (on the NIM master) and uses streams to cache all of the data from the client to these file systems.
The advantages and disadvantages to this function are as follows:
nimadm -j rootvg ...
or nimadm -j cachevg
# lsnim -a location SpotName
Nim_Client.nimadm_cache.excl
Spot_Location/Nim_Client.nimadm_cache.excl
For
example: /nim_resources/520spot/usr/myclient.nimadm_cache.excl.With disk caching, the nimadm command changes the following four phases (all other phases remain the same) :
Phase 2: The NIM master creates local cache file system in specified target volume group (on the NIM master).
Phase 3: The NIM master populates the cache file systems with the client's data.
Phase 9: The NIM master writes all migrated data to the client's alternate rootvg.
Phase 10: The NIM master cleans up and removes the local cache file systems.
nimadm Requirements
nimadm Limitations
NIM resources used by nimadm:
The nimadm Migration Process
nimadm Cleanup Operation
This operation, indicated with the "-C" flag, is designed to clean up after a failed migration that for some reason did not perform a cleanup it self. It can also be used to clear a previous migration in order to perform a new migration.
nimadm Wake-up and Sleep
After a migration completes, the nimadm command can be used to "wake-up" the migrated altinst_rootvg or the original rootvg (if booted from the migrated disk). The nimadm wake-up (-W flag) performs an alt_disk_install wake-up, NFS exports the /alt_inst file systems, and mounts them on the NIM master. The nimadm sleep function (-S flag) reverses the wake-up by unmounting the NIM master mounts, unexporting the /alt_inst file systems, and executing the alt_disk_install sleep function on the client.
Item | Description |
---|---|
-a PreMigrationScript | Specifies the pre-migration NIM script resource. |
-b installp_bundle | Specifies the installp_bundle NIM resource. |
-B | Specifies not running bootlist after the nimadm migration. If set, then -r flag cannot be used. |
-c ClientDisks | Specifies the NIM defined client which is the target of this nimadm operation. This flag is required for all nimadm operations. |
-C | Performs nimadm cleanup. |
-d TargetDisks | Specifies the client target disk which is used to create altinst_rootvg (the volume group that is migrated). |
-D | Sets the nimadm command into debug mode. This function must only be used to debug nimadm related problems and is not set by default. |
-e exclude_files | Specifies the exclude_files NIM resource. This resource is used by the alt_disk_install command during Phase 1. |
-E | Enters the nimadm debugger if a serious migration error occurs. |
-F | Forces a client to unlock. Normally, the nimadm command locks a client to perform various operations. While the client is locked, other nimadm or NIM operations cannot be performed. This flag must ONLY be used in the unusual condition that a client is incorrectly locked (this can happen if for some reason the nimadm command could not call cleanup after a failure). |
-i image_data | Specifies the image_data NIM resource. This resource is used by the alt_disk_install command during Phase 1 and 11. |
-j VGname | Creates file systems on the specified volume group (on the NIM master) and uses streams to cache all of the data from the client to these file systems. |
-l lpp_source | Specifies the lpp_source NIM resource to be used for this nimadm operation. This flag is required for migration operations. |
-m NFSMountOptions | Specifies arguments that are passed to the mount command that mounts client resources on the master. This flag can be used to tune nimadm related NFS performance. |
-M | Verifies that the levels of the alt_disk_install software (bos.alt_disk_install) on the NIM master, SPOT, lpp_source, and optional device are synchronized (match). If there is no match, the nimadm command installs the highest level found in the lpp_source or optional device. |
-N NIMmksysb | Specifies the unique new NIM mksysb resource to create. If the -N flag is specified, the -O flag must be specified. |
-o bosinst_data | Specifies bosinst_data NIM resource. |
-O mksysbfile | Specifies the file pathname for the migrated mksysb. If the -O flag is specified, the -j flag and either the -c or -T flag must be specified. |
-P Phase | The phase to execute during this invocation of the nimadm command. If there is more then one phase, the phases must be separated by spaces or commas. Valid phases are 1 through 12. |
-r | Specifies that the client must reboot after nimadm migration is complete. |
-s SPOT | Specifies the SPOT NIM resource to be used for this nimadm operation. This flag is required for all nimadm operations. |
-S | Performs the nimadm "sleep" function. This function must be executed to end a nimadm "wake-up". |
-T NIMmksysb | Specifies an existing NIM mksysb resource to migrate. If the -T flag is specified, the -j flag and either the -O or -c flag must be specified. |
-V | Turns on verbose output. |
-W | Performs the nimadm "wake-up" function. |
-Y | Agrees to required software license agreements for software to be installed. |
-z PostMigrationScript | Specifies the post-migration NIM script resource. |
Access Control: You must have root authority to run the nimadm command.
Attention RBAC users and Trusted AIX users: This command can perform privileged operations. Only privileged users can run privileged operations. For more information about authorizations and privileges, see Privileged Command Database in Security. For a list of privileges and the authorizations associated with this command, see the lssecattr command or the getcmdattr subcommand.
nimadm -c aix1 -s spot1 -l lpp1 -d "hdisk1 hdisk2" -Y
nimadm -c aix1 -s spot1 -a nimscrip1 -z nimscript2 -l lpp1 -d hdisk1 -Y
nimadm -C -c aix1 -s spot1
nimadm -c aix1 -s spot1 -l lpp1 -O /export/mksysb/mksysb1 -j vg00 -Y -N nim1
nimadm -s spot1 -l lpp1 -j vg00 -Y -T nim2 -O /export/mksysb/m2 -N nim3
nimadm -c aix1 -s spot1 -l lpp1 -d hdisk1 -j vg00 -T nim2 -Y
Item | Description |
---|---|
/usr/sbin/nimadm | Contains the nimadm command. |